
Visual Studio Code
สาํหรับผู้เริ่มต้น



Visual Studio Code
● เปน็โปรแกรมประเภท Code Editor หรือเครื่องมอืสาํหรับใชใ้นการเขยีน

โปรแกรมที่ไดร้ับความนิยมในปจัจุบนั เหมาะสาํหรับนักพฒันาทุกระดบั

● รองรับการทํางานบน Windows , macOS , Linux

● รองรับการเขยีนโปรแกรมไดห้ลายภาษา

● ใชง้านไดฟ้รี มขีนาดเล็กและทํางานไดอ้ย่างรวดเร็ว

● ม ีสว่นเสริม (Extension) ชว่ยอํานวยความสะดวกในการเขยีนโปรแกรม



ภาพรวมเน้ือหา

● พืน้ฐานการใชง้าน Visual Studio Code

● Command Palette

● การจัดการโฟลเดอร์และไฟล์

● การจัดการ Editor (พืน้ที่สาํหรับใชใ้นการเขยีนโค้ด)



ภาพรวมเน้ือหา
● Workspace

● Terminal

● Extension

● Profiles

● คีย์ลัดพืน้ฐาน



หน้าจอโปรแกรม (User Interface)
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*หมายเหต ุ: หน้าจอโปรแกรมอาจมกีารปรับเปลี่ยนตามเวอร์ชั่นที่ใชง้าน



การตรวจสอบเวอร์ชั่น
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● Menu Bar เปน็แถบเมนูที่รวมคําสั่งทั้งหมดใน Visual Studio Code

Menu Bar
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Primary Side Bar  แถบเมนูที่อยู่ดา้น

ขา้งโปรแกรม สาํหรับแสดงรายละเอียดการ

ทํางานของเครื่องมอืที่อยู่ใน Activity Bar

Primary Sidebar
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Primary Side Bar  แถบเมนูที่อยู่ดา้น

ขา้งโปรแกรม สาํหรับแสดงรายละเอียดการ

ทํางานของเครื่องมอืที่อยู่ใน Activity Bar

Activity Bar
Primary Side Bar

Primary Sidebar



Activity Bar  แถบเครื่องมอืประกอบดว้ย

เครื่องมอื ดงัน้ี

● Explorer

● Search

● Source Control

● Run and Debug

● Extensions

Activity Bar



● Explorer สว่นที่ใชส้าํหรับแสดงรายชือ่

รวมถงึจัดการโฟลเดอร์และไฟล์ตา่งๆ

โดยจะแสดงโฟลเดอร์และไฟล์ทั้งหมด

เปน็ลําดบัชั้นทําใหเ้ขา้ถงึขอ้มลูในสว่น

ตา่งๆ ไดง้่ายและรวดเร็ว   

Activity Bar



● Search สว่นที่ใชส้าํหรับค้นหา

ขอ้มลูตา่งๆที่กาํลังเปดิใชง้าน

ในโปรแกรม

Activity Bar
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● Source Control สว่นที่ใช้

ควบคุมการทํางานเกีย่วกบั 

Source Code ผ่าน Git , 

GitHub

Activity Bar



● Run and Debug สว่นที่ใช้

สาํหรับการรันและตรวจสอบ

การทํางานของโปรแกรม

Activity Bar
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Activity Bar

● Extension จัดการสว่นขยาย

หรือสว่นเสริมภายในโปรแกรม 

เพือ่เพิม่ประสทิธิภาพการทํางาน



● Editor เปน็พืน้ที่สาํหรับใชใ้นการเขยีนโค้ด



● Editor เปน็พืน้ที่สาํหรับใชใ้นการเขยีนโค้ด

Minimap สาํหรับแสดงภาพรวมของ

เน้ือหาที่อยู่ในไฟล์



● Editor เปน็พืน้ที่สาํหรับใชใ้นการเขยีนโค้ด

ตาํแหน่งของไฟล์ที่ใชง้านอยู่ (Breadcrumb)

Minimap สาํหรับแสดงภาพรวมของ

เน้ือหาที่อยู่ในไฟล์



● Editor เปน็พืน้ที่สาํหรับใชใ้นการเขยีนโค้ด

ตาํแหน่งของไฟล์ที่ใชง้านอยู่ (Breadcrumb)

Minimap สาํหรับแสดงภาพรวมของ

เน้ือหาที่อยู่ในไฟล์
Glyph Margin พืน้ที่สาํหรับทํางานกบั 

Breakpoint



● Status Bar พื้นที่สาํหรับแสดงรายละเอียดต่างๆ เช่น จํานวนบรรทัด , 

ภาษาที่เขียน , Extension ที่เกี่ยวข้อง เปน็ต้น
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● Panel พืน้ที่แสดงรายละเอียดตา่งๆ เชน่ การแสดงผล (Output) , 

การแจ้งขอ้ผิดพลาด (Problem) , การตรวจสอบ (Debug) และ 

Terminal เปน็ตน้

Panel



การใชง้านเบือ้งตน้
● การตั้งค่า Theme

● การตั้งค่าขนาดข้อความ

● ซ่อน-แสดง Minimap

● เปดิ-ปดิ Glyph Margin



การใชง้านเบือ้งตน้
● Full Screen - โหมดเตม็จอ

● Zen Mode - โหมดโฟกสั (ไมม่ ีTab ดา้นขา้ง)

● การย่อ-ขยายผ่านคีย์บอร์ด (Zoom)

● การย่อ-ขยายผ่านเมาส ์(Mouse Wheel Zoom) 



ขอ้ควรรู้เกีย่วกบัการตั้งค่า

● ค่าเริ่มตน้



ขอ้ควรรู้เกีย่วกบัการตั้งค่า

● ค่าเริ่มตน้

● เปลี่ยนแปลงการตั้งค่า



ขอ้ควรรู้เกีย่วกบัการตั้งค่า

● ค่าเริ่มตน้

● เปลี่ยนแปลงการตั้งค่าเสน้กาํกบั
เพือ่บอกวา่มี

การเปลี่ยนแปลง
การตั้งค่า



ขอ้ควรรู้เกีย่วกบัการตั้งค่า

● ค่าเริ่มตน้

● เปลี่ยนแปลงการตั้งค่า

● รีเซ็ตการตั้งค่า



Command Palette

สว่นที่ใชใ้นการแสดงคําสั่งทั้งหมดหรือคําสั่งที่มกีารใชง้านบอ่ยเปน็

เครื่องมอืทางลัดที่อํานวยความสะดวกในการเรียกใชง้านคําสั่งตา่งๆ

ภายในโปรแกรมไดร้วดเร็วมากยิ่งขึ้น ใชก้ารคลิกที่น้อยลง เชน่ การตั้ง

ค่า , การจัดการไฟล์ การรีเซ็ตตาํแหน่ง View , อื่นๆ เปน็ตน้



แสดง Command Palette

1. กด F1 หรือ Ctrl + Shift+P

2. View -> Command Palette

3. Manage -> Command Palette



จัดการโฟลเดอร์

● เปิด - ปิดโฟลเดอร์

● สร้าง - ลบโฟลเดอร์

● เปลี่ยนชื่อโฟลเดอร์

● โฟลเดอร์ย่อย

● การย้ายโฟลเดอร์ (Drag and Drop)



เปิดโฟลเดอร์

1
● Explorer-> Open Folder
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เปิดโฟลเดอร์

2

● File -> Open Folder
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เปิดโฟลเดอร์

ชือ่โฟลเดอร์ที่เปดิ



เปิดโฟลเดอร์

ชือ่โฟลเดอร์ที่เปดิ



ปิดโฟลเดอร์
● File -> Close Folder

● หรือกดคีย์ลัด Ctrl+K F 



สร้างโฟลเดอร์

1

● กดไอคอน New Folder

● ตั้งชื่อโฟลเดอร์



สร้างโฟลเดอร์

● คลิกขวาพื้นที่ว่าง Explorer 

● New Folder…

● ตั้งชื่อโฟลเดอร์

2



ลบโฟลเดอร์

● คลิกขวาโฟลเดอร์ที่ตอ้งการลบ 

● เลือกเมนู Delete

● ยืนยันการลบ

1



ลบโฟลเดอร์

● เลือกโฟลเดอร์ที่ตอ้งการลบ

(กรณีลบหลายโฟลเดอร์ใหก้ด Ctrl ร่วมดว้ย) 

● กดปุม่ Delete

● ยืนยันการลบ

2



เปลี่ยนชื่อโฟลเดอร์

1

● คลิกขวาโฟลเดอร์ที่ต้องการเปลี่ยนชื่อ 

● เลือกเมนู Rename…

● ตั้งชื่อใหม่



เปลี่ยนชื่อโฟลเดอร์

2

● เลือกโฟลเดอร์ที่ตอ้งการเปลี่ยนชือ่ 

● กดปุม่ F2

● ตั้งชือ่ใหม่



สร้างโฟลเดอร์ย่อย

1 ● เลือกโฟลเดอร์หลัก 

● กดไอคอน New Folder

● ตั้งชือ่โฟลเดอร์ย่อย



สร้างโฟลเดอร์ย่อย
● คลิกขวาที่โฟลเดอร์หลัก 

● เลือกเมนู New Folder

● ตั้งชือ่โฟลเดอร์ย่อย

2



การย้ายโฟลเดอร์ (Drag and Drop)

1. เลือกโฟลเดอร์ที่ตอ้งการย้าย

(กรณีย้ายหลายโฟลเดอร์ใหก้ด Ctrl ร่วมดว้ย)

2. ลาก-วางไปยังตาํแหน่งโฟลเด

อร์ปลายทางที่ตอ้งการ

1

2



จัดการไฟล์
● สร้างไฟล์ใหม ่- เปลี่ยนชือ่ไฟล์

● การบนัทึกไฟล์ 

● การลบไฟล์

● การเปดิ-ปดิไฟล์

● การย้ายไฟล์ (Drag and Drop)

● สร้างโฟลเดอร์และไฟล์ในครั้งเดยีว



สร้างไฟล์ใหม่

1

● กดไอคอน New File

● กําหนดชื่อไฟล์และนามสกลุไฟล์



สร้างไฟล์ใหม่

2

● File -> New File…

● กาํหนดรูปแบบไฟล์



● คลิกขวาพืน้ที่วา่ง Explorer

● เลือกเมนู New File…

● กําหนดชื่อไฟล์และนามสกุลไฟล์

สร้างไฟล์ใหม่

3



● คลิกขวาไฟล์ที่ตอ้งการเปลี่ยนชือ่

● เลือกเมนู Rename

● ตั้งชือ่ไฟล์ใหม่

เปลี่ยนชื่อไฟล์

1



● เลือกไฟล์ที่ตอ้งการเปลี่ยนชือ่

● กดปุม่ F2

● ตั้งชือ่ไฟล์ใหม่

เปลี่ยนชื่อไฟล์

2



การบันทึกไฟล์

● ไฟล์ที่ยังไมถ่กูบนัทึกจะมเีครื่องหมายจุดสขีาวตอ่ท้ายชือ่ไฟล์

● Open Editors จะแจ้งจํานวนไฟล์ที่ยังไมม่กีารบนัทึก



การบันทึกไฟล์

● ไฟล์ที่ยังไมถ่กูบนัทึกจะมเีครื่องหมายจุดสขีาวตอ่ท้ายชือ่ไฟล์

● Open Editors จะแจ้งจํานวนไฟล์ที่ยังไมม่กีารบนัทึก

ยังไมบ่นัทึกไฟล์



การบันทึกไฟล์

● ไฟล์ที่ยังไมถ่กูบนัทึกจะมเีครื่องหมายจุดสขีาวตอ่ท้ายชือ่ไฟล์

● Open Editors จะแจ้งจํานวนไฟล์ที่ยังไมม่กีารบนัทึก

ยังไมบ่นัทึกไฟล์



การบนัทึกไฟล์ (เฉพาะไฟล์ที่สนใจ)

● File -> Save

● กดคีย์ลัด Ctrl + S



การบนัทึกไฟล์ (ทั้งหมด)

● File -> Save All

● กดคีย์ลัด Ctrl + K S

1



การบนัทึกไฟล์ (ทั้งหมด)

● Open Editors

● กดไอคอน Save All2
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ตั้งค่าบนัทึกอัตโนมตั ิ(Auto Save)
● เมนู File

● Auto Save



การลบไฟล์

● คลิกขวาไฟล์ที่ตอ้งการลบ

● เลือกเมนู Delete

● ยืนยันการลบ

1

1



การลบไฟล์

● เลือกไฟล์ที่ตอ้งการลบ

(กรณีลบหลายไฟล์ใหก้ด Ctrl ร่วมดว้ย)

● กดปุม่ Delete

● ยืนยันการลบ

2



การเปิดไฟล์

● File -> Open File 

● เลือกไฟล์ที่ตอ้งการเปดิใน Editor

1
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การเปิดไฟล์

● กดคีย์ลัด Ctrl + O 

● เลือกไฟล์ที่ตอ้งการเปดิ2
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การปิดไฟล์

● กดเครื่องหมายกากบาท (x) ใน

ไฟล์ที่ตอ้งการปดิ1
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การปิดไฟล์

● คลิกขวาที่ไฟล์ -> เลือกเมนู Close

● หรือกดคีย์ลัด Ctrl + F4

2 (กรณีปดิหลายไฟล์ใหเ้ลือกเมนู Close All)



การย้ายไฟล์ (Drag and Drop)

1. เลือกไฟล์ที่ตอ้งการย้าย

(กรณีย้ายหลายไฟล์ใหก้ด Ctrl ร่วมดว้ย)

2. ลาก-วางไปยังตาํแหน่งโฟลเด

อร์ปลายทางที่ตอ้งการ



การสร้างโฟลเดอร์และไฟล์ในครั้งเดยีว

โครงสร้างคําสั่ง

● ชือ่โฟลเดอร์หลัก / ชือ่โฟลเดอร์ย่อย / ชือ่ไฟล์.นามสกลุไฟล์

ตวัอย่าง

● layouts/pages/footer.html



การสร้างโฟลเดอร์และไฟล์ในครั้งเดยีว

โครงสร้างคําสั่ง

● ชือ่โฟลเดอร์หลัก / ชือ่โฟลเดอร์ย่อย / ชือ่ไฟล์.นามสกลุไฟล์

ตวัอย่าง

● layouts/pages/footer.html



จัดการ Editor

● Previews Mode

● การจัดการแท็บ (Tabs)

● Sticky Scroll 

● Editor Groups



จัดการ Editor

● Editor Layout

● Sort Lines

● Transform



Previews Mode

เปน็โหมดแสดงผลตวัอย่างเน้ือหาในไฟล์ที่เปดิใชง้านใน Editor 

เมือ่มกีารเปดิไฟล์ใหมก่จ็ะแทนที่เน้ือหาเดมิใน Editor ใหอ้ัตโนมตัิ

ซ่ึงมคีวามสะดวกอย่างมากในการดภูาพรวมและแกไ้ขเน้ือหาใน

ไฟล์ที่เปดิใชง้านภายในแท็บเดยีว



Previews Mode

สามารถดเูน้ือหาภายในไฟล์

ที่ตอ้งการผ่านแท็บเดยีวกนั

ไดเ้ลย



Previews Mode

ไฟล์ที่เปดิผ่าน Preview Mode

ชือ่ไฟล์จะเปน็ตวัอักษร

ตวัเอยีง



Previews Mode
ถา้ตอ้งการเปดิไฟล์ในแท็บ Editor 

แบบถาวร โดยไมม่กีารแทนที่เน้ือหาให้

ดาํเนินการดงัน้ี

1. Double Click ที่ไฟล์

2. Double Click ที่แท็บ Editor

*ชือ่ไฟล์ที่เปดิใน Editor จะเปน็ตวัอักษรปกติ

*กรณีที่มกีารแกไ้ขขอ้มลูในไฟล์จะเปน็โหมดปกติ



การจัดการแท็บ (Tabs)

● กาํหนดรูปแบบการแสดงแท็บ 

● Pin Tabs 

● Wrap Tabs 



กาํหนดรูปแบบการแสดงผลแท็บ

View -> Appearance -> Tab Bar

● Single (แท็บเดยีว) 

● Multiple Tabs (หลายแท็บ)

● Hidden (ซ่อนแท็บ)



Pin Tabs

● Pin คือ การปกัหมดุแท็บ 

Editor ที่มคีวามสาํคัญ

ใหย้้ายไปอยู่ลําดบัแรก

หรือดา้นหน้าสดุ



● การปกัหมุด

คลิกขวาที่แท็บ -> Pin

● การยกเลิก

คลิกขวาที่แท็บ -> Unpin

Pin Tabs



● การปกัหมุด

คลิกขวาที่แท็บ -> Pin

● การยกเลิก

คลิกขวาที่แท็บ -> Unpin

Pin Tabs



Wrap Tabs

สาํหรับจัดการแท็บที่เกนิพืน้ที่ ใหไ้ปอยู่ในบรรทัดถดัไป

เพือ่ใหแ้ท็บการทํางานทั้งหมดอยู่ในระดบัเดยีวกนั

https://www.facebook.com/KongRuksiamTutorial/https://www.youtube.com/c/KongRuksiamOfficial/

https://www.facebook.com/KongRuksiamTutorial/
https://www.youtube.com/c/KongRuksiamOfficial/


การตั้งค่า Wrap Tabs

● Manage -> Settings -> Wrap Tabs

● เปดิใชง้าน (Enabled)



Sticky Scroll

การกาํหนดใหต้รึงคําสั่งตดิกบัขอบ 

Editor เมือ่มกีารเลื่อนไปถงึ 

ใชส้าํหรับบอกขอบเขตการทํางาน



การตั้งค่าเปดิ-ปดิ Sticky Scroll

● Views -> Appearance

● เลือก Sticky Scroll

https://www.facebook.com/KongRuksiamTutorial/https://www.youtube.com/c/KongRuksiamOfficial/

https://www.facebook.com/KongRuksiamTutorial/
https://www.youtube.com/c/KongRuksiamOfficial/


Editor Group

การแยกหน้าจอทํางานของ Editor ออกเปน็กลุ่มหรือ

หมวดหมูเ่พือ่ใหง้่ายตอ่การบริหารจัดการ Editor



Editor Layout

การกําหนดเค้าโครงการแสดงผล

การทํางานของ Editor โดยแบ่ง 

Editor ออกเปน็หลายๆสว่นตาม

รูปแบบมาตรฐานที่กําหนด



Editor Layout

การกําหนดเค้าโครงการแสดงผล

การทํางานของ Editor โดยแบ่ง 

Editor ออกเปน็หลายๆสว่นตาม

รูปแบบมาตรฐานที่กําหนด



Sort Lines

เรียงลําดบัขอ้มลูที่อยู่ในไฟล์ผ่าน Command Palette

● Ascending (น้อยไปมาก)

● Descending (มากไปน้อย)



Transform

การเปลี่ยนรูปแบบตวัอักษรที่อยู่ในไฟล์ ตวัอย่าง เชน่

● Uppercase (ตวัพมิพใ์หญ่)

● Lowercase (ตวัพมิพเ์ล็ก)

● อื่นๆ



Outline และ Timeline

Outline คือ สว่นที่แสดงภาพรวมและเขา้ถงึโครงสร้างคําสั่งของ

ไฟล์ที่เปดิใน Editor ในลักษณะของลําดบัชั้น 



Outline และ Timeline

Timeline คือ สว่นที่ชว่ยตดิตาม

ประวตัขิองไฟล์ , ขั้นตอนการทํางาน

ในไฟล์ที่เปดิใน Editor รวมถงึ

เปรียบเทียบคําสั่งกอ่น-หลังแกไ้ข

เน้ือหาในไฟล์ 



Workspaces

Workspaces  คือ สว่นที่ใช้บริหารจัดการโฟลเดอร์ที่จะนํามาทํางาน

ร่วมกันอย่างเต็มรูปแบบ

Single-Folder Workspaces



Workspaces

Workspaces  คือ สว่นที่ใช้บริหารจัดการโฟลเดอร์ที่จะนํามาทํางาน

ร่วมกันอย่างเต็มรูปแบบ

Multi-Root Workspaces



ขั้นตอนการสร้าง Workspace

● File -> Add Folder To Workspace 

● File -> Save Workspace As…

● ตั้งชือ่ Workspace (.code-workspace)



โครงสร้างไฟล์ .code-workspace

{

"folders": [

{

"path": "ตาํแหน่งโฟลเดอร์"

},

]

}



การปรับแตง่ Workspace
● Manage->Settings 

● แท็บ Workspace

● เลือกโฟลเดอร์ใน Workspace

● ตั้งค่าหรือปรับแตง่

(ขอ้มลูการตั้งค่าจะอยู่ในโฟลเดอร์ .vscode)



การปดิ Workspace

● File -> Close Workspace

การเปดิ Workspace

● File -> Open Workspace from File..

● เลือกไฟล์ Workspace (.code-workspace)



Search และ Replace

● Search สว่นที่ใชส้าํหรับค้นหา

ขอ้มลูตา่งๆที่กาํลังเปดิใชง้าน

ในโปรแกรม

https://www.facebook.com/KongRuksiamTutorial/https://www.youtube.com/c/KongRuksiamOfficial/

https://www.facebook.com/KongRuksiamTutorial/
https://www.youtube.com/c/KongRuksiamOfficial/


รูปแบบการค้นหา

● Match Case ค้นหาโดยจําแนกตวัอักษรพมิพเ์ล็ก - พมิพใ์หญ่

● Match Whole Word ค้นหาขอ้ความที่เหมอืนกนัทุกอย่าง

● Use Regular Expression ค้นหาผ่านการกาํหนด Pattern หรือ

รูปแบบกลุ่มคํา (ตอ้งมพีืน้ฐาน Regex)



Replace สว่นที่ใชส้าํหรับการแทนที่

เน้ือหา ประกอบดว้ย

● Preserve Case แทนที่และกาํหนดเงื่อนไข

ตามรูปแบบตวัอักษรพมิพเ์ล็ก-พมิพใ์หญ่

● Replace All แทนที่ทั้งหมด

Search และ Replace



Terminal
ในการเขยีนโปรแกรมบางครั้งตอ้งอาศยัการเขยีนคําสั่งผ่าน Command 

Line หรือ Terminal เพือ่ดาํเนินการตา่งๆ ซ่ึงอาจจะเปน็คําสั่งเฉพาะหรือ

คําสั่งที่เปน็ของระบบปฎิบตักิาร เชน่ การจัดการโฟลเดอร์ การตดิตั้งไลบลาลี่ 

รวมถงึการรันและทดสอบโปรแกรม ตวัอย่างคําสั่งพืน้ฐาน เชน่

● cd ไปยัง directory ที่กําหนด , cls สาํหรับเคลียร์หน้าจอ



ตวัอย่างคําสั่งของ VSCode

● code - -help  ดูรายละเอียดคําสั่งทั้งหมดใน Visual Studio Code

● code - - version เรียกดูเวอร์ชั่นของ Visual Studio Code

● code .  หมายถึง เปิด directory ปจัจุบัน

● code ตําแหน่งไฟล์ที่ N หมายถึง เปิดไฟล์ที่กําหนดตามตําแหน่งที่ระบุ



การสร้าง Terminal

● Terminal -> New Terminal

การลบ Terminal

● กด Kill Terminal

Terminal

แสดง Terminal

● View -> Terminal

ซ่อน Terminal

● กดไอคอน x ที่ Terminal



การกาํหนดรูปแบบ Terminal

● View -> Terminal

● เมนู  Launch Profile…

● เลือก Select Default Profile

● เลือกรูปแบบ Terminal ที่ต้องการ



● Extension สว่นขยายหรือสว่น

เสริมภายในโปรแกรมสาํหรับ

เพิม่ประสทิธิภาพการทํางาน

Extension



การแสดง Extension

1. ไอคอน Extension ใน Activity Bar

2. View -> Extension

Extension



● Search ชอ่งค้นหา Extension ที่เราสนใจ

● Installed แสดงรายชือ่ Extension 

ที่ตดิตั้งใน Visual Studio Code แล้ว

● Popular & Recommended แสดงรายชือ่

และแนะนํา Extension ที่ไดร้ับความนิยม

Extension



● เลือก Extension

● กดเมนู Install (ตอ้งเชือ่มตอ่อินเทอร์เน็ต)

ตดิตั้ง Extension



1. เลือก Extension -> Uninstall

2. เลือก Extension -> Manage -> Uninstall

ถอนตดิตั้ง Extension



1. เลือก Extension -> Disable

2. เลือก Extension -> Manage -> Disable

ปิดการใช้งาน Extension



1. เปิด Command Palette

2. พิมพ์คําสั่ง Disable All Installed 

Extensions

ปดิการใชง้าน Extension (ทุกตวั)



เปิดการใช้งาน Extension

1. เลือก Extension -> Enable

2. เลือก Extension -> Manage -> Enable



เปิดการใช้งาน Extension (ทุกตัว)

1. เปดิ Command Palette

2. พมิพค์ําสั่ง Enable All Extensions



Filter เปน็ตัวกรอง Extension 

ที่เกี่ยวข้องโดยจําแนกตามหมวดหมู่

ต่างๆ  เช่น 

● AI 

● Programming 

● Testing 

● อื่นๆ

Filter Extension



Sort เปน็การจัดเรียง Extension 

ตามรูปแบบที่กาํหนด เชน่ 

● จํานวนการตดิตั้ง

● เรตติง้

● ชือ่

● อื่นๆ

Sort Extension



Profiles

เปน็ระบบที่อยู่ใน Visual Studio Code ใชส้าํหรับรวบรวม

สิง่ต่างๆ เข้าไว้ด้วยกัน เพื่อใหเ้หมาะสมกับการจัดการโปรเจกต์ 

ที่ได้รับมอบหมายหรือการกําหนดสภาพแวดล้อมตามที่

นักพัฒนาต้องการ เช่น การตั้งค่า , การติดตั้ง Extension ต่างๆ 



ปญัหาที่เกดิขึ้น

การพฒันาระบบเราไมไ่ดเ้ขยีนโปรแกรมแค่ภาษาเดยีว เชน่ 

● ระบบ A ใชภ้าษา Python 

● ระบบ B ใชภ้าษา JavaScript 

● ระบบ C ใชภ้าษา Java



ปญัหาที่เกดิขึ้น



ปญัหาที่เกดิขึ้น

สง่ผลใหนั้กพฒันาตอ้งตั้งค่ารวมถงึตดิตั้ง Extension 

มากมายเพือ่ใหส้ามารถพฒันาระบบและเขยีนโปรแกรม

ภาษาดงักล่าวได ้ทําใหเ้กดิความยุ่งยากในการบริหารจัดการ



Profiles

ในการใชง้าน Visual Studio Code เราสามารถแยกกลุ่มการตั้งค่า

ตา่งๆ หรือตดิตั้ง Extensions ใหเ้หมาะสมกบัการเขยีนโปรแกรมหรือ

การพฒันาระบบตามสภาพแวดล้อมที่เราตอ้งการไดผ้่านระบบ Profile

(โปรไฟล์เริ่มตน้คือ Default Profile)



ใชร้ะบบ Profiles

Default Profile



Profile B

Profile C

Profile A

ใชร้ะบบ Profiles



Profile B

Profile C

Profile A

ใชร้ะบบ Profiles

สามารถสลับและแชร์โปรไฟล์ได้



Profile B

Profile C

Profile A

ใชร้ะบบ Profiles

สามารถสลับและแชร์โปรไฟล์ได้



Profile B

Profile C

Profile A

ใชร้ะบบ Profiles

สามารถสลับและแชร์โปรไฟล์ได้



การสร้าง Profiles
● Settings -> Profiles -> New Profile

● ตั้งชือ่ Profile 

● กาํหนด Icons ให ้Profile

● ตั้งค่า Contents

● กด Preview เพือ่ดตูวัอย่าง หรือ กด Create  เพือ่สร้าง Profile



Profiles Contents

● Setting คือ การตั้งค่าตา่งๆที่ใชง้านร่วมกบั Profile

● Keyboard Shortcut คือ การตั้งค่าคีย์ลัดที่ใชง้านร่วมกบั Profile

● Tasks คือ การตั้งค่า Task ที่ใชง้านร่วมกบั Profiles

● Snippets คือ การตั้งค่า Snippets (คําสั่งสาํเร็จรูป) ที่ใชง้านร่วมกบั Profile

● Extension คือ สว่นขยายที่ใชง้านร่วมกบั Profile



Profiles Contents

Contents Source

● Default อ้างอิง Content จาก Default Profile

● None ไมก่าํหนด Content



การสลับ Profiles

1. File -> Preferences -> Profile -> เลือก Profile

2. Manage -> Profile -> เลือก Profile

3. Manage -> Profile -> Profiles -> เลือก Profile -> Use this Profile….

4. Command Palette -> พมิพค์ําสั่ง Switch Profile -> เลือก Profile



การสง่ออก Profile (Export)

1. เลือก Profile

2. กด More Actions…

3. Export -> เลือกรูปแบบการสง่ออก (Local , GitHub)



การนําเขา้ Profile (Import)

1. Settings -> Profiles -> New Profile

2. กด More Actions…

3. Import Profile… -> ชือ่ไฟล์.code-profile

4. กด Preview เพือ่ดตูวัอย่าง หรือ กด Create  เพือ่สร้าง Profile



การลบ Profile (Delete)

1. เลือก Profile

2. กด More Actions…

3. เลือกเมนู Delete 

4. ยืนยันการลบ



Profile Template
Profile สาํเร็จรูป ที่อยู่ใน Visual Studio Code (Built-In Profiles)

ซ่ึงได้มีการจัดเตรียมเคร่ืองมือพื้นฐานพร้อมนําไปใช้งานได้เลย 

โดยใน Template น้ันได้มีการกําหนดการตั้งค่าพื้นฐาน , Extension , 

Snippets ที่เหมาะสมกับงานหรือรูปแบบการเขียนโปรแกรมของแต่ละ

ภาษาเรียบร้อยแล้ว เช่น Python , Java , Node.js เปน็ต้น



การสร้าง Profile Template

1. Settings -> Profiles -> New Profile

2. กด More Actions…

3. From Template

4. เลือก Template ที่ตอ้งการ


